No luck on Mac need help

Any questions regarding getting Jaymod running.
Post Reply
backharlow
Server n00b
Posts: 1
Joined: Fri Apr 24, 2009 10:29 pm

No luck on Mac need help

Post by backharlow » Fri Apr 24, 2009 11:16 pm

Okay so there are several other forum posts dating back several years for this. No one seems to ever come back to these posts and give any resolution whatsoever. Support from Jaymod developers is present but ineffective. Answers like "Your setup is incorrect. Look at it again," are not helpful when the user does not have the same psychic connection to the code as the developer. We cannot read minds.
The Mac binary isn't getting used, even though it is there in the proper folder with all other conditions met. If the reason is that the Mac binary just doesn't work, tell us, so we can move on. If not, let's go over it, and if there is some trick, maybe that can be put in documentation.

Code: Select all

ERROR: characters/temperate/axis/soldier.char, line 16: unknown token 'undressedModel'
********************
ERROR: ERROR: G_RegisterPlayerClasses: failed to load character file 'characters/temperate/axis/soldier.char' for the Axis Soldier

********************
----- Server Shutdown ----
Today I installed a fresh copy of ET 2.6 on Mac 10.5 (PPC).
Installed fresh copy of Punkbuster that comes with et.
Neither app has ever resided on this OS before.
Grabbed a fresh copy of the full download of Jaymod 2.0.6.
Put the contents of the tarball in a folder I made: jaymod in my et folder (beside etmain).
Added: exec jaymod.cfg to my et server.cfg
ran:

Code: Select all

./rtcw_et_server +set dedicated 1 +set com_hunkmegs 128 +set fs_game jaymod +exec server.cfg
and the print:

Code: Select all

ET 2.60 MacOS-PPC Mar 16 2005
----- FS_Startup -----
Current search path:
/Users/daniel/Library/Application Support/Wolfenstein ET/jaymod
/Applications/Wolfenstein ET/jaymod/jaymod-2.0.6.pk3 (190 files)
/Applications/Wolfenstein ET/jaymod
/Users/daniel/Library/Application Support/Wolfenstein ET/etmain
/Applications/Wolfenstein ET/etmain/pak2.pk3 (22 files)
/Applications/Wolfenstein ET/etmain/pak1.pk3 (10 files)
/Applications/Wolfenstein ET/etmain/pak0.pk3 (3725 files)
/Applications/Wolfenstein ET/etmain/mp_bin.pk3 (6 files)
/Applications/Wolfenstein ET/etmain

----------------------
3953 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Sys_InitNetworking -----
... InitOpenTransport()
... OTOpenEndpoint()
... OTBind()
Opened UDP endpoint at port 27960
LocalAddress: 192.168.1.71
Netmask: 255.255.255.0
LocalAddress: 0.0.0.0
Netmask: 0.0.0.0
------------------------------
...detecting CPU, found PowerPC G4
Bypassing CD checks
Found high quality video and fast CPU
--- Common Initialization Complete ---
Working directory: /Applications/Wolfenstein ET
execing server.cfg
sv_maxclients will be changed upon restarting.
execing jaymod.cfg
execing objectivecycle.cfg
g_gametype will be changed upon restarting.
------ Server Initialization ------
Server: oasis
Hunk_Clear: reset the hunk ok
----- FS_Startup -----
Current search path:
/Users/daniel/Library/Application Support/Wolfenstein ET/jaymod
/Applications/Wolfenstein ET/jaymod/jaymod-2.0.6.pk3 (190 files)
/Applications/Wolfenstein ET/jaymod
/Users/daniel/Library/Application Support/Wolfenstein ET/etmain
/Applications/Wolfenstein ET/etmain/pak2.pk3 (22 files)
/Applications/Wolfenstein ET/etmain/pak1.pk3 (10 files)
/Applications/Wolfenstein ET/etmain/pak0.pk3 (3725 files)
/Applications/Wolfenstein ET/etmain/mp_bin.pk3 (6 files)
/Applications/Wolfenstein ET/etmain

----------------------
7906 files in pk3 files
Mach-O bundle qagame loaded
------- Game Initialization -------
gamename: etmain
gamedate: Mar 16 2005
------------------------------------------------------------
InitGame: \g_maxlivesRespawnPenalty\0\voteFlags\0\g_balancedteams\0\g_maxGameClients\0\g_covertopsChargeTime\30000\g_soldierChargeTime\20000\g_LTChargeTime\40000\g_engineerChargeTime\30000\g_medicChargeTime\45000\g_bluelimbotime\30000\g_redlimbotime\30000\gamename\etmain\g_heavyWeaponRestriction\100\g_gametype\2\g_antilag\1\g_voteFlags\0\g_alliedmaxlives\0\g_axismaxlives\0\g_minGameClients\8\g_needpass\0\g_maxlives\0\g_friendlyFire\1\sv_allowAnonymous\0\sv_floodProtect\1\sv_maxPing\0\sv_minPing\0\sv_maxRate\13000\sv_minguidage\0\sv_punkbuster\1\sv_maxclients\20\sv_hostname\Mueller Jaymod @ Delroy6-leopard\sv_privateClients\4\mapname\oasis\protocol\84\timelimit\0\version\ET 2.60 MacOS-PPC Mar 16 2005
Gametype changed, clearing session data.
Enable spawning!
Disable spawning!
0 teams with 0 entities
-----------------------------------
^3PunkBuster Server: pb_sv_SsNext = 758175 (0 to 999999)
^3PunkBuster Server: pb_sv_LogNext = 4 (1 to 999999)
^3PunkBuster Server: 0 Power Players loaded from /Users/daniel/Library/Application Support/Wolfenstein ET/pb/pbpower.dat
^3PunkBuster Server: 0 PB Rcon Filters loaded from /Users/daniel/Library/Application Support/Wolfenstein ET/pb/pbrcon.dat
^3PunkBuster Server: 0 Map lines loaded from /Users/daniel/Library/Application Support/Wolfenstein ET/pb/pbsvmaps.cfg
^3PunkBuster Server: PunkBuster Server (v1.123 | A1344 C1.130) Enabled
^3PunkBuster Server: 0 Aliases Written to /Users/daniel/Library/Application Support/Wolfenstein ET/pb/pbalias.dat
^3PunkBuster Server: 0 Stat Records Written to /Users/daniel/Library/Application Support/Wolfenstein ET/pb/pbstat.dat
^1ERROR: characters/temperate/axis/soldier.char, line 16: unknown token 'undressedModel'
********************
ERROR: ERROR: G_RegisterPlayerClasses: failed to load character file 'characters/temperate/axis/soldier.char' for the Axis Soldier

********************
----- Server Shutdown -----
==== ShutdownGame ====
ShutdownGame:
------------------------------------------------------------
---------------------------
^3PunkBuster Server: Game Version [ET 2.60 MacOS-PPC Mar 16 2005]
execing preset_high.cfg
So the filesystem inclusion of the files in the jaymod folder suggests that the +set +set fs_game jaymod is being accepted. But then it doesn't run anything, and defaults to etmain, and then dies.
What can be done at this point excluding answers like "reinstall et".

Thank for all the hard work.
Backharlow

Post Reply